Alfa newbie - Is this normal? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 26-11-03 Thread Starter
Status: -
AO Member
Join Date: May 2003
Location: Nottingham
Posts: 19

Member car:

147 1.6 Lusso

Alfa newbie - Is this normal?

Hello All!

I've had my 147 for a month or so now and have noticed a couple of things recently that which I'm not sure whether to be worried about or not. I'm getting a quite pronounced creaking from the front suspension for the first couple of miles, but only when going really slowly over speed bumps. Is this something my dealer is likely to be able to fix / be interested in (Ha!), or is it just a 'feature'?

Also coming back to my car after a few hours today there was a load of condensation on the front and rear windscreen. Didn't really expect this sort of thing with climate control. I'd had it on the last time I drove it, so was surprised (thought that would have sucked all the moisture out of the air). I've done a quick check round for wet carpets and leaks, but everything seems to be fine. Has anyone else had this problem?
davenottm is offline  
Sponsored Links
Status: - Update
Posts: n/a
I find that as well in this weather. Not too concerned to be honest, stick the quick clear on and it's gone in a minute or so.
Status: Wyrd is Life
AO Gold Member
Stori's Avatar
Join Date: Nov 2002
County: -
Posts: 11,590
I would liberally spray all the suspension joints and rubber bushes including those on the anti-roll bar with WD 40 or Silicon Oil. I also spray the Springs and top shock mounts. Won't do any harm and will more than likely stop squeak.
If it does not fix the problem then probably need to see the dealer.
I have traditionally done this every 3 months or so will all my Alfa's since 1979.
Stori is offline  
Status: -
AO Silver Member
amyndas's Avatar
Join Date: Sep 2003
Location: Thessaloniki
Posts: 1,081
Images: 7
<blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:<hr /><font size="1" face="Verdana, Helvetica, sans-serif">Originally posted by Stori:
<strong>I would liberally spray all the suspension joints and rubber bushes including those on the anti-roll bar with WD 40 or Silicon Oil.</strong><hr /></blockquote><font size="1" face="Verdana, Helvetica, sans-serif">Agree 100% esp. about the anti-roll bar.It is most likely the one that creaks and squeels
amyndas is offline  
Status: -
AO Member
Join Date: Apr 2003
Location: Kent, England
Posts: 24
Hi Dave

Had a similar thing from the rear suspension on my 147, gave it a good seeing to with some silicon spray and the problem has gone away. Good luck

cfcnick is offline  
Status: where is life going
AO Silver Member
Dupes's Avatar
Join Date: Sep 2003
Location: Southampton
Posts: 1,352
Condesation on mine was a misrouted windscreen washer hose - over the air blower intake, so rain water was running along the pipe and dripping into the pollenfilter - thus really 'wet air' was being sent into the car. You could try checking that.

Note that the carpets are quite water resistant - you need to check under the carpets.

a light mist may be normal, but droplets of condensation aint good!
Dupes is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
it is better (but ackward) to switch off aircon a few miles before the destination. The iced condenser then has time to dry out, if you stop while the aircon was still running, the condensor thaws and the moisture will vent into the car (and water will drop under the car as well, but this is normal with aircon, you should see the parking spaces in Phoenix AZ).)
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alfa , newbie , normal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome