trouble starting, and warm weather weirdness - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-04-09 Thread Starter
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Carmarthenshire
Posts: 129

Member car:

156 2.0

Hmmm trouble starting, and warm weather weirdness

Hi all,

I've had very long running power loss problems on my 2.4jtd, pretty much everything has been replaced or tested at some point (see my previous posts) and now has 2 garages stumped...

However just recently since the weather has got warmer 2 weird things have started to happen.

first the power loss is not as bad as it used to be, still drops off when put under load, but general driving is defiantly better (tho far from right).

however, its really struggling to start now all the time (only did it occasionally before) the engine will normally turn over for a good 5-6 seconds, splutter a few times then fire up properly, all be it with a HUGE cloud of smoke. it always starts eventually, and very occasionally it will start first time no problem.

any ideas???

had always thought my starting problems and power loss were related. only suggestion I've ever been given is an iffy injector(s) that may be leaking slightly, but that's never added up to me as runs very smoothly once started (and not under load)
dodge00 is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
Re: trouble starting, and warm weather weirdness

* glow plugs ok?

* compression ok?

* re-mapped ecu?

* fuel pump pressure ok?

* fuel fitler replaced recently?
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

starting , trouble , warm , weather , weirdness

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome