156 Engine Damage - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Silver Member
McGuinn's Avatar
Join Date: Mar 2003
Location: Dublin, Ireland.
Posts: 3,194

Member car:

145 1.8 TS

<blockquote><font size="1" face="Verdana, Helvetica, sans-serif">quote:<hr /><font size="1" face="Verdana, Helvetica, sans-serif">Originally posted by rarebear:
p.s. you can spot bad drivers if they have dirty alloys !!! </strong><hr /></blockquote><font size="1" face="Verdana, Helvetica, sans-serif">What are you implying??? Eh??? We have dirty roads!
McGuinn is offline  
Sponsored Links
Status: Daddy bear
Global Mod Team
bazza's Avatar
Join Date: Nov 2002
Location: Congleton - The centre of
Posts: 42,041
Images: 3

Member car:

Alfa 156 GTA SW

Phew! That was good timing, mine were bloody filthy but I cleaned them this afternoon
bazza is offline  
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
you see !!!!
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , damage , engine

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome