break pads - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 23-04-09 Thread Starter
Status: -
Join Date: Apr 2009
Location: United Kingdom
County: -
Posts: 2

Member car:

147 Sport

break pads

Hi I'm new to this and need some help. My 147 sport is in for its 36k service and they are saying that my pads need to be stripped and cleaned to stop my steering wheel from juddering everytime i press on the breaks. They're saying that if that fails then i need to replace them. Not sure how many miles the pads should do but surely more than 36k. Can anyone help how long should they last!!
phillipacobb is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: break pads

I've got a 156 and they lasted around 70K ...

The juddering could be that they have "glazed over" .. they've overheated at some stage and have developed hardened surfaces. What they plan to do is to scratch the surface up with a rough file or similar ... you'll need to bed them in again as if they were new.

Let me know if it works .. our Clio judders as well
gazza82 is offline  
Status: -
AO Member
qawsed's Avatar
Join Date: Mar 2008
Posts: 569
Images: 2
Re: break pads

Pads are very cheap anyway. Got a set for 30 euro for the rear of my 156 and they're perfect.
qawsed is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

break , pads

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome