Powerflex on 147 Upper Wishbones - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-04-09 Thread Starter
Status: 60% Retired and still Pedantic
AO Member
Ken's Avatar
Join Date: Jan 2002
Location: United Kingdom
County: Falkirk
Posts: 893
Images: 32

Member car:

Alfa 159 3.2 Q4

Powerflex on 147 Upper Wishbones

I fitted Powerflex bushes to the upper wishbones on Mrs Ken's 147 at 32900 miles in Nov 2007.

Last week there was a tremendous cacophony from the front every time the suspension moved .

When I stripped the upper wishbones they were completely dry of lubricant - at 44776 miles.

The big washers that come with the Powerflex kit are now corroded quite badly - these would probably be better in stainless steel.

Fitted new smaller diameter but thicker washers and applied lashings of Kluber Unisilicon TK44 NO grease and the suspension is silent again
Ken is offline  
Sponsored Links
Status: Saving for engine.
AO Silver Member
tomfromtelford's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,244
Images: 54
Re: Powerflex on 147 Upper Wishbones

good tip, im looking at this soon
tomfromtelford is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , powerflex , upper , wishbones

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome