Motor Control System Failure - Code P0420 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 15-04-09 Thread Starter
Status: Deceased
AO Member
Join Date: Jul 2007
Location: United Kingdom
County: West Midlands
Posts: 24
Help Motor Control System Failure - Code P0420

Afternoon everyone,

I had the Motor control error pop up a couple of days back, I got the code read and it came back with P0420 - Catalyst system efficiency below threshold Bank 1.

What exactly does this mean? Is it a dead lamda sensor? Also how do I know which is bank 1 as there are 2 lamda's on the manifold and another one lower down I think. Or is it a dead cat?

Just for info my car is a 147 Selespeed 2.0Lt TS (2002).

Last thing, is it safe to drive or am I going to ruin my cats? The cats are only about 6 months old and I'd hate to replaced them again


Mute147 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

code , control , failure , motor , p0420 , system

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome