HELP- My car thinks its a Diesel ?! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-04-09 Thread Starter
Status: Waiting for 159 Replacement
AO Member
nueva alfista's Avatar
Join Date: Jul 2006
Location: W London & Gloucester
Posts: 218
Images: 1

Member car:

AR GT>Juke>Brera

HELP- My car thinks its a Diesel ?!

Today driving back from Oxfordshire my centre information panel suddenly produced a message saying that there is 'water in diesel' and some other error message about glow plugs. It was raining as well. I find this strange because its petrol. Any ideas, advice would be welcome.

Recently I have had the lambda sensor changed and this is only the second time this has happened both in wet weather conditions. My car is suffereing from hesitation issues between 2000 and 3000 rpm with motor control failure light and alarm coming on for about 3 seconds and then going back to normal. Oh yeah I think that my fuel consumption has dropped by about 10%.

What course of action should I take? Many thanks

"Knowledge is power but character is respect" - Bruce Lee

GT= gone
Juke = gone
Brera = 'HELLLLO'
nueva alfista is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: HELP- My car thinks its a Diesel ?!

Could it be water leaking into the ecu that is giving you all the problems.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

car , diesel , thinks

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome