156 Climate Control nightmare! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 03-04-09 Thread Starter
Status: -
Join Date: Jan 2009
Location: United Kingdom
County: Tyne and Wear
Posts: 2

Member car:

156 sportwagon

156 Climate Control nightmare!

Hello one and all for my sins a 156 Sportwagon owner. Had a 156 saloon that did 38000 in 20 months with not a jot wrong, is this a first?! Love the Sportwagon (03) although the usual electric bugs seem to be appearing!!!
Ive got the climate control problem that a few have posted. The thing has a mind of its own!! Trying to turn it down results in the opposite and have to resort to switching out and turning passenger down to engage aircon then resetting. It also does the 'swith to blowing on feet at a ridiculous temp' for no reason. Dealer reset display to Celcius but tis has made 0 difference. Any ideas would be beyond welcome!
alfaceeps is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: 156 Climate Control nightmare!

Cure is in this thread:


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , climate , control , nightmare

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome