Connect Nav Bust - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Connect Nav Bust

Hi all,

I have a 147 with Connect Nav + coming up to 2 years old.

Yesterday I took it to a dealer (Mangoletsi Knutsford UK) to have a couple of small glitches fixed before the warranty ran out.

Picked it up yesterday evening and now the Sat Nav no longer works. The position on the map is drifting further and further from my real position, and if I remove the CD, my position is reported as Latitude, Longtitude and Altitude all zero (even though it does report 7 satellites received).

I know for sure it was working fine when I arrived at the dealer yesterday morning.

I will call them this morning.

Does anyone else have experience of similar issue?

Sponsored Links
Status: -
AO Member
Chappy's Avatar
Join Date: Jan 2002
Location: Lichfield
Posts: 744
Roll up....roll up for the mystery tour!

Does the arrow move further away when you are at standstill?

I don't have any answers but I just wanted to see what was happening for future reference.
Chappy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

bust , connect , nav

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome