oil pressure on 2.0 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 01-04-09 Thread Starter
Status: -
AO Member
Join Date: Nov 2008
Location: United Kingdom
County: Dorset
Posts: 14

Member car:


Help oil pressure on 2.0 147

Hi, Oil pressure warning came on for a couple of seconds when I turned the ignition on (not started engine), should I be worried? The car is a 54 plate with 28000 on the clock. All levels are fine although I do have a faint knocking noise from the engine on tick over. Is it anything to worry about.

The weather was extremely cold when the pressure light flashed up.

plasterman44 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Mar 2006
Location: United Kingdom
County: Staffordshire
Posts: 689
Re: oil pressure on 2.0 147

The warning light should come on when the ignition is turned on, but not when the engine is running.
sensingsys is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , oil , pressure

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome