having no cat - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
having no cat

I need some help? Has any one out there removed there cat from the exhaust on the 1.8 ts engine? and if so how much power did u get from it?
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,990
I've removed the CAT from my Euro2 spec 2.0TS Selespeed.
Don't think it gave much more power though (maybe a little).
The single lambda sensor is before the CAT so it doesn't know that it is nolonger there, so the ECU is still happy.
It will need to go back on for the MOT though.

You don't say how old your 1.8TS is, if it is a Euro3 or 4 spec car removing the CAT is not so simple.
They have a lambda sensor AFTER the CAT, the ECU will see that there is a problem with the CAT (because it isn't there!) and reduce engine power.

David C

Audi TT 3.2v6 DSG
xAlfa 156 Selespeed sp3 + Brembo conversion
Fiat Cinquecento 899cc
David C is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome