VDC Failure - anyone help? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 21-03-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2006
Location: United Kingdom
County: Lancashire
Posts: 124
Help VDC Failure - anyone help?

A bit of a techie one this.

I have VDC failure following a steering column stalk switch change.

Now I know this is probably the clock spring, so I changed it for the one that was working on the old switch unit. Initially it showed no fault then at the first corner the fault reappeared.

So, I tried to play around with the 'new' broken one - pulling it apart to see if I could see what might be wrong.

Looking at it I can see that the gearing on the front part of the clock spring is such that the system's gears return to the same point after two complete rotations of the wheel. Would it record a VDC failure if this was turned through 360 degrees or would the system self detect the start position?

Secondly, I pulled apart the middle bit - into which the front part of teh clock spring plugs and I see it is a long ribbon coiled around the centre many times. Anyone know what the start position setting is.

Alternatively, can I just buy the clockspring bit to replace or do I need another whole new switch unit (which is ridiculously expensive).

If anyone can help, I would be grateful,
chc is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

failure , vdc

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome