147 electrics - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-03-09 Thread Starter
Status: -
Join Date: Mar 2009
Location: United Kingdom
County: Essex
Posts: 3

Member car:

Alfa 147

147 electrics

Hello everyone, can anyone help me? I have a 147 Lusso, I've had it for a couple of weeks now, fantastic, love it, but I have a problem with the wipers, they just suddenly stopped working, and will now only slowly jump across the screen, also the headlight washers just keep spraying at random times, also I got the car with no owners manual so if anyone knows where I can get one, that would be great, thanks very much.
dogboy is offline  
Sponsored Links
Status: -
AO Silver Member
SLM3CFC's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Greater London
Posts: 2,363
Re: 147 electrics

Ebay might have an owners manual if you keep checking.. I've seen some manuals on a disk, not sure if it's the one your looking for..
I'm sure someone will reply about the electrics shortly
SLM3CFC is offline  
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Re: 147 electrics

Hmmm - sounds like a body computer issue..

The devices are on a serial bus - wiring isnt point to point.
cj romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , electrics

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome