Curious warning light issue - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 17-03-09 Thread Starter
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Cambridgeshire
Posts: 415
Images: 4

Member car:

Ford Focus

Curious warning light issue

This morning it was a bit chilly but hardly the arctic conditions we've had.
A symbol that looked the same as the one on top of the selespeed oil pot flashed up on my HUD. Obviously, there was much clenchy. Then, after about 10 seconds, it went off. Turned around went back to the house, read the manual and, helpfully, couldn't find a reference to it. The gearbox seems fine.
The light hasn't come on since. The selespeed oil was replenished at the Alfa dealer last week (cheers to Donalds of Peterborough); what might the problem be?
nayf is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
Re: Curious warning light issue

did you check the level of the selespeed oil (tutella cs) ?
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

curious , issue , light , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome