Help!!! Engine problem ... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-08-03 Thread Starter
Status: -
AO Member
Join Date: Jul 2002
Location: London, UK
Posts: 319
Help!!! Engine problem ...


I had my car (1999 model) serviced in June. Suspension parts changed.

However, I've noticed over the last few weeks that the engine sounds very very very rough - like a tractor when revving >3000 rpm ... has the exhaust got a hole or is the engine damaged? Done < 30,000 miles - what's happening? PLease help .
Oil was checked a couple of weeks ago
Harp is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2003
Location: suffolk/oxfordshire
Posts: 746
I know that earlier (i.e older than your car)
twinsparks have problems with the variator.
This sounds like a diesel at low end revs
if it has gone,so maybe that is a possibility?
tony24 is offline  
Status: Now driving a BMW :(
AO Platinum Member
RicksAlfas's Avatar
Join Date: Sep 2002
Location: West Yorkshire
Posts: 17,033
Images: 11

Member car:

1750GTV 147Lusso

Total guess - It could be the balancer shaft belt that's snapped.
Is it OK at idle and low revs??
If it's noisy at low revs, it could be the variator, but if it's only over 3000, it could be the balancer belt.
Does it feel rough??

Maybe a plug has gone down, but I am sure you would notice this at any revs.

Only other thing is maybe an engine mount has gone.

Sorry. Hope you get it sorted soon!!!!!
RicksAlfas is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome