156 - Airbag warning lights - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-08-03 Thread Starter
Status: Elder and role model
AO Silver Member
PAJ's Avatar
Join Date: Mar 2003
Location: Chepstow
Posts: 1,004
Images: 10
156 - Airbag warning lights

The driver and passenger airbag warning lights have come on on my 2.5 yr old 156. Has anyone experienced this, and can give me an idea of what to expect when I take it to the dealer to be looked at?

They started coming on intermittently a month or so ago. Sometimes they'll come on when I start the car, they'll then stay on for about 20 minutes, then flash a few times and go off. Other times, they'll just stay on for the whole journey (an hour or more). And other times they won't come on at all (although this has become increasingly rare recently).

Could this just be an electrical fault? And if so, what are your opinions as to how much I might be charged to get it fixed? Or could it be a more serious fault?
PAJ is offline  
Sponsored Links
Status: -
AO Silver Member
dc's Avatar
Join Date: Feb 2002
Location: United Kingdom
County: Hertfordshire
Posts: 1,037

Member car:

Brera 2.2 JTS

I've no personal experience of this but read somewhere recently that it is sometimes possible to have the chip concerned reset for about 15. Failing that the article reckoned it cost about 150 for some sort of overhaul/replacement.

As I said, I only read this so can't vouch for its accuracy but it might be of some help..

dc is offline  
Status: Now driving a BMW :(
AO Platinum Member
RicksAlfas's Avatar
Join Date: Sep 2002
Location: West Yorkshire
Posts: 17,033
Images: 11

Member car:

1750GTV 147Lusso

It's often a loose connection under the front seats if you have side airbags. Can be caused by moving the seat around a lot - say if you share the car with someone else.
Failing that, it can be a break in the connections behind the dash. The money involved is how long's a piece of string....
RicksAlfas is offline  
Status: -
AO Silver Member
Simes's Avatar
Join Date: May 2003
Location: Lancashire, UK
Posts: 1,609
Images: 10
I had this problem with my 156,

it turned out that the connector for the side airbags (in the seat) was dodgy on the drivers side. The cable sits loose under the seat on mine so it's something that could get damaged/come loose which would tie in quite well with an intermittent > getting worse scenario...

It only took my dealer (well two of them actually - the first got it's liecence revoked half way through) 6 months to sort including 2 ECU's and a new seat..

EDIT - Bahh bloody work - phone going whilst I'm replying


Alfa V6 - the ultimate aural pleasure
Simes - the Alfaowner formerly known as Alfa156man
Simes is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , airbag , lights , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome