Connect Nav + Unit needs replacing after 8mths!!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Connect Nav + Unit needs replacing after 8mths!!!

I don't beleive it!
I just don't beleive it
I took my 147 to Bishops in Guildford to have the brakes, steering and the stereo looked at. Came back a day later and they tell me the whole stereo, sat nav, phone and connect unit needs replacing because they got some errors from the diagnostsics that they did not understand so they thought it better to replace the whole thing.

Not very happy. The car is 8mths old, been in the garage 3 times and now parts are already needing to be replaced. What made it worse is the servicing guy sneering and told me he was not suprised as this sort of thing always goes wrong???

Always goes wrong? How the **** do they think they can charge 1800 quid for the unit and it lasts 8mths ?

I am not happy to say the least.

Don't get me wrong I love the car and all the little electrical problems are sort of understandable on the bella but it was the attitude of the guy that really annoyed me.

To make things worse some kids were sitting on the bonnet of the car last week and when they ran they left the bonnet concaved in with a massive dent! Alfa looked and said 310 quid for a new one painted and fitted.

anyway enough ranting and back to surfing ebay for alfa bits...

Sponsored Links
Status: - Update
Posts: n/a
Rich sorry to hear your probs. Your car is same age as mine more or less, and I have connect Nav+ too.

Anyways, I took my 147 to Bishops earlier this year for a VDC/ABS issue. They had it for 6 weeks, and guess what, the car still has the fault. To top it off, the car was scratched on the lower front skirt, and I'm 100% positive it wasn't there before I left the car with them.

It maybe a distance for you, but I heard good things about Cleavland cars in Ash, and also Alan Gibson in Basingstoke...

I'm certainly not taking my car back to Bishops..
Status: - Update
Posts: n/a
yeah I have my doubts about Bishops. Will let them replace the unit and then start using elsewhere. Might see about L&M International in High Wycombe who look after alfa and fiats. Not sure about the newer ones though. They were brilliant with my coupe.

After I bought the motor I took it back to have the cruise control sortware updated(or thats what they told me) and it came back with a crack in the windscreen which I know was not there before. They denied it and I still have the crack.

Love the car, hate the company...

somethings never change


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

8mths , connect , nav , replacing , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome