Turbo failure on JTD's common? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 01-03-09 Thread Starter
Status: -
AO Member
Gustav_H's Avatar
Join Date: Oct 2006
Location: Sweden
County: Västra Götaland
Posts: 195
Turbo failure on JTD's common?


My car have been standing at the workshop now for about two weeks waiting for a new turbo. The car started to loose power and had problems going up hill. After the workshop had picked out the error-codes they disassembled and found the IC full with oil. Not a good thing.

My car(156 1,9JTD 16V Q4) only have made 110000km and have been served according to the book. Is it common that these Garret turbos fail so early? Should I change the oil more common than the book says?

Fortunatley I still have warranty on my car, since I bought it last december. So I don't have to pay for it. But it's not fun when yor car i standing in the workshop all the time...

Alfa 156 CW Q4
Alfa 75 3,0 V6 America
Gustav_H is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

common , failure , jtd , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome