first mods to my 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 05-07-03 Thread Starter
Status: -
AO Member
dave 147's Avatar
Join Date: Jun 2003
Location: England
Posts: 231

Member car:

147 selespeed

first mods to my 147

i have had my selespeed for jt over 4 weeks now i have ordered a carbo fiber look momo zorst trim and some anti theft vale caps with the alfa logo on them,

i was just wondering what were the first and small mods people did to there as i dont want to afected the warentry

all advices and coments welcome

dave 147 is offline  
Sponsored Links
Bob Maes
Status: - Update
Posts: n/a
My first mod were white side indicators

A small mod but it looks great!
Status: Wondering
AO Member
Toonster's Avatar
Join Date: Nov 2002
Location: United Kingdom
County: Northumberland
Posts: 175
White Autodelta side indicators, which look nice but are quite fragile, one side now being "secured" with blue-tack after one retaining lug snapped off.

Autodelta aluminium radio aerial, looks nice but does little for radio reception. Make sure you specify the right diameter thread if you buy one, as there are 2 sizes.

K+N air filter, which is fairly easy to fit and may have a slightly beneficial effect on engine note and power output, although this may be psychological self-delusion.

Alfa Romeo stainless steel sill scuff plates, which fit easily and look nice, but don't drive with your doors open whilst admiring them.

Ecotek CB26P, which did nothing I could detect apart from making an embarassing tone-deaf owl noise whilst driving on a trailing throttle - not recommended. Now removed: don't be tempted.

Next up is an Autodelta "easy to fit - bolts straight on!" (oh, good) strut brace: another candidate for self-delusion, I expect. And, later, some 17" alloy wheels to replace my 16" ones - stop sniggering at the back.

And I love it.
Toonster is offline  
Status: -
AO Member
T07's Avatar
Join Date: Nov 2002
Location: Upper Barclay. Carrow Road.
Posts: 435
56 weeks into ownership. Cursed the car for the first week, tried to sell it - would've lost 5k so....... Not missed a beat since so glad I kept it, only 'mod' was to fit black side indicators, though stupidly expensive from AO. Next mod will be to chop it for a GTA Selespeed if it ever appears.....

Tempted to fit FM signal booster as the Connect Nav + unit is not very good
T07 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , mods

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome