Alternator wiring - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Alternator wiring

Got a letter from the dealer a few weeks ago. Apparently there has been a problem with some of the alternators not being reconnectde to the battery, and the battery subsequently being run down...(Marius, an AO forum member had this problem).

Now they'r doing a recall to check the wiring. Maybe you continentals should have a look perhaps you have the same problem.

Have not yet taken mine to the dealer, but still waiting on them to get parts for the "selespeed recall" that they idea when all of these recalls will take place!
Sponsored Links
Status: -
AO Member
DengKao's Avatar
Join Date: Nov 2002
Location: tuk tuk tukkerland
Posts: 908

Member car:

147 1.9 JTD 16V

Hmmm, didn't I mention it to you before? (about the alternator not being hooked on).

Wow I actually was right. Woohoow.

Good for you they found the problem!

DengKao is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

alternator , wiring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome