temperature gauge probloem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 18-02-09 Thread Starter
Status: -
Join Date: Feb 2009
Location: United Kingdom
County: Lincolnshire
Posts: 8
temperature gauge probloem

I'm having problems with my temperature gauge on my 147, the gauge is graduated in 8ths and upon start up it initally sits at cold then rises rapidly to 3/8ths, then drops back down to 1/8ths and so on until the car warm where it sits at 90 (half gauge). On any other car this would be the temperature sendor unit or as its an alfa is it dodgy headlight wiring or a rear tailgate switch? Lol. Can anyone advise on this? Thanks

Last edited by 147 steve; 18-02-09 at 18:34.
147 steve is offline  
Sponsored Links
Status: AO Member
AO Member
Bigdog73's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Hampshire
Posts: 74
Re: temperature gauge probloem

147 Steve- It will almost certainly be the thermostat, I had exactly the same problem with my 147 JTD £50 for a new stat and it rise linear to 90 degrees and stays there.
Bigdog73 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

gauge , probloem , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome