Misfiring 156 2.5v6 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 13-02-09 Thread Starter
Status: -
Join Date: Feb 2009
Location: United Kingdom
County: Merseyside
Posts: 2
Not Happy Misfiring 156 2.5v6

I have just joined & was wondering if anyone can help me with my misfiring 156 2.5 v6 24v. When cold it is a nightmare misfiring and cutting out! When warmed up it is still a pain although slightly better but very much down on power! and takes some encouragement to pull away. I have tried it with the mass air valve disconnected and it is the same! It had a new cam belt fitted with new plugs and ran fine after! The first fault was a flat spot at 5000 rpm and has progressively got worse! There is no fault showing light showing. Any help or suggestions would be gratefully recieved. Cheers.
ginjazx12r is offline  
Sponsored Links
Status: -
AO Member
Alfa Mike's Avatar
Join Date: Jul 2008
Location: United Kingdom
County: Merseyside
Posts: 38
Images: 4
Re: Misfiring 156 2.5v6

Hi, where (garage name) & when did you have the cambelt etc. changed, maybe the timing is out or possibly the lambda needs replacing, also check if there's any oil/water in the spark plug wells, I'm having similar problems and replaced both the lambda & maf but the engine is still not 100%, slight hesitation/jerkiness when accelerating at lower speeds and flatspots as well.
Alfa Mike is offline  
Status: Bavarian
Admin Team
bobda's Avatar
Join Date: Jul 2002
County: -
Posts: 15,247
Images: 13

Member car:

Not a GT

Re: Misfiring 156 2.5v6

If you've tried with the MAF removed and it's the same, then you've found the problem. Congratulations.
bobda is offline  
Status: -
AO Member
autorazzo's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Scottish Borders
Posts: 284
Re: Misfiring 156 2.5v6

I would not say maf, disconecting Maf should improve. If the problems still persist then it may be something else.

Does it Idle OK?

I would go with what Alfa Mike is saying.

Check you are getting a good spark first and then come back to us with the result.
autorazzo is offline  
Status: - Update
Posts: n/a
Re: Misfiring 156 2.5v6

Coil packs in good condition?

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , misfiring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome