Shuddering/vibration on take off!! Clutch or Rev sensor?? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 06-02-09 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 51

Member car:

Alfa Romeo 159

Shuddering/vibration on take off!! Clutch or Rev sensor??


I have a 2003 156 selepseed JTS...

I have been experiencing shuddering/vibration when taking off lately, it comes and it goes and is particularly noticeable and more violent when the car is colder, then dissapears...the only other time that it is noticeable is during extreme hot days as the symptoms rears its unpleasant head from time to time..we have had temperatures over 45degrees celsius consecutively over 5 days recently and it is still quite hot.

I also notice that when I flick to city mode it settles this problem down somewhat...anyway does anyone have any clues as to what this "alfa-ism' may be...??

I was thinking more along the lines of rev-sensor as opposed to clutch, considering i have done 110,000km i wouldnt imagine it would be clutch...also it doesnt happen all the time...
fmd159 is offline  
Sponsored Links
Status: -
AO Silver Member
abarth sav's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Essex
Posts: 2,690

Member car:

all alfas

Re: Shuddering/vibration on take off!! Clutch or Rev sensor??

sounds like your clutch is on its way out,look there first, on city mode,the clutch is released smoothly

good luck
abarth sav is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

clutch , rev , sensor , shuddering or vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome