Clutch click - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Clutch click

When releasing the clutch pedal, just before it bites there is a clunking noise like it is catching on something - tried spraying it with WD40 - no joy!! any ideas ??
Sponsored Links
Status: Now driving a BMW :(
AO Platinum Member
RicksAlfas's Avatar
Join Date: Sep 2002
Location: West Yorkshire
Posts: 17,033
Images: 11

Member car:

1750GTV 147Lusso

RicksAlfas is offline  
Status: -
AO Member
Join Date: Dec 2002
Location: UK
Posts: 53
I actually get the same thing, but occutionally... still haven't figured it out. In general my clutch is quite 'hard' so I will get it checked on next service.
f0rCeGr0wn is offline  
Status: -
AO Member
Join Date: Dec 2002
Location: Netherlands
Posts: 66

Member car:

alfa 147 jtd 16v

I had the same thing when my car was brand new. After about 2000 km's the clutch was 'broken in' and I've never had that problem again.
It sounded like the clutch was getting stuck just before reaching the highest point (total release). Just releasing the clutch gave the clicking sound. Very annoying, thank god it's gone now.

Wouldn't know how to fix your specific situation though (I'd go to the dealer, because the clutch is a total pain it the behind like that)
Cornelis Zijlstra is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

click , clutch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome