GT 2.0 JTS SatNav CD unit problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-01-09 Thread Starter
Status: -
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3

Member car:

Alfa GT 2.0 JTS

GT 2.0 JTS SatNav CD unit problems

Just bought a Gt and there were probllems with the SatNav the disc was damaged. Sat Nav seems ok now but audio CD's skip/jump when going over relatively small bumps or when I tap the steering wheel. I checked the tyre pressures and found that they were over-inflated. After deflating them to correct pressures, the problem lessened slightly but still the Cd's regularly skip! Any ideas of causes/remedies?

Geoffrave is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: GT 2.0 JTS SatNav CD unit problems

yeah i had this problem, i didnt fix it tho i went round it, by fitting an ipod connection

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

jts , problems , satnav , unit

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome