Alfa 147 shockers - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 25-01-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2007
Posts: 12

Member car:

alfa romeo 147

Lick Alfa 147 shockers

I have at last installed Koni FSD shockers on my 147 2 litre(700). Where, in the past,I found the ride very"twitchy" when hustled through side roads and rather uneasy even on main roads at high speeds.Now the car is far more planted and more pleasurable to drive fast.I did consider Eibach springs but was advised by the supplier( who stocks both) that the FSDs alone would be greatly beneficial. I hope I have done the right thing.The Alfa now sits slightly lower at the rear ;not a bad thing. Generally, I'm pleased with the change.Perhaps now a remap: Red Dot, what can I expect?
If anybody is interested in the original shockers( 19000milies) please make me an offer.
TEE is offline  
Sponsored Links
Status: -
AO Member
vindaloo's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Greater Manchester
Posts: 306
Re: Alfa 147 shockers

It's interesting that your car sits slightly lower at the back as a lot of people report a slight raising of the ride height particularly at the back.
FSD's are designed to be used with stock or mildy lowered (sports) springs so you're decision is sound, although the Eibach Pro's as we know are an admirable choice as well.
vindaloo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , shockers

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome