Engine Temperature Sensor. Hunting Revs - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 17-01-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2007
Posts: 51

Member car:


Engine Temperature Sensor. Hunting Revs

Hello All. Te 156 2.0TS

I am having trouble with the revs hunting between 400 - 2500.
Before I tackle this I need to change the engine temperature Sensor. Where do I find it please, how do I recognise it.

(Alfadiag keeps reporting P0115 'Engine temp sensor below min limit. Keeps coming back even if codes reset) . Thought I would fix this first incase it confuses the diagnostics of the real problem.

On the revs questions I have cleaned the air intake Maf. Checked out the throttle etc on alfadiag-OK. Done an ECU reset to ensure the throttle actuator calibration. Any other guidance greatfully received.

Also can anyone tell me about the Actuator tests in Alfadiag. When you run them it says 'test complete'. I suspect this simply means that the device in question has been sent the needed signal for it to respond. Whether or not it responded OK is then maybe a matter of observation? (Or maybe it really does test out the device fully?)

any help greatfully received. Regards
perkiss is offline  
Sponsored Links
Status: Tin worm attack ... ARGHH!
AO Gold Member
gazza82's Avatar
Join Date: Jan 2003
Location: United Kingdom
County: Buckinghamshire
Posts: 8,285
Images: 12
Re: Engine Temperature Sensor. Hunting Revs

It's on top of thermostat housing ... take off engine cover and remove air intake pipes. Simply unscrews from body. There are pics, etc on my website (link in signature below). Duff sensor will not help as ECU will be altering fuel mix to compensate ... so when low, over fuels/rich, etc.

You should be able to hear the actuator tests taking place ... lift the bonnet and listen.
gazza82 is offline  
(Post Link) post #3 of 4 Old 17-01-09 Thread Starter
Status: -
AO Member
Join Date: Apr 2007
Posts: 51

Member car:


Re: Engine Temperature Sensor. Hunting Revs

Thanks Gary,

Lots of usefull stuff on your site - Very Good. Unfortunatly had a good search cannot see any photo of 'Engine Temparature Sensor' Location. Have I missed It?. Is it the same as the 'coolant temarature' as discussed in other post's? Anyway I can't see that either!


PS. I can hear the various actuators working (making a noise) but was hoping against hope that the 'test' might be more rigorouse than that. A bit new to Alfadiag - sorry to be dumb.
By the way, what is it with Alfa's. I just sold my Omega which I had from new to 130K miles. Never had a warning light or electronic defect in the whole 9 years???
perkiss is offline  
Status: - Update
Posts: n/a
Re: Engine Temperature Sensor. Hunting Revs

Always Loved Forever Annoyed, bet its much better and puts a bigger smile on your face than a bloody vauxhall though.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , hunting , revs , sensor , temperature

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome