Engine Management Light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-01-09 Thread Starter
Status: Back in UK
AO Member
gleggzer's Avatar
Join Date: Nov 2008
Location: United Arab Emirates
County: Dubayy
Posts: 633
Help Engine Management Light


My engine management light comes on every so often, with no loss of power etc when driving the car.

The light normal goes out after the car has warmed up and i have re-started it.

Also i have noticed that when the light does come on, the cooling fan seems to kick in, even tho the car hasnt been driven and the engine is cold!

Does this sound like a new battery would solve the problem? or does some sensor needs replacing?


gleggzer is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
Re: Engine Management Light

best to get the car diagnosed rather than wasting money on unnecessary parts.
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome