147 indicators acting strangely? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
147 indicators acting strangely?

Just got my car a couple of weeks ago and have noticed that the indicators are acting a bit oddly...

1. Sometimes when I indicate left they dont switch off after I return the steering wheel to the centre position. Seems to be ok when make 90 degree turns, but roundabouts etc. are not.

2. When turning right (going round a roundabout, say) they switch off even if you move the steering wheel left a tiny amount.

Is this normal?

Other than that the car has been problem free and an absolute joy. Im beginiing to think this dodgy reputation Alfas have is just made up by Alfa Owners to scare off BMW drivers that are starting to think 'what if?'
Sponsored Links
Status: -
AO Member
Join Date: Oct 2002
Location: Belgium
Posts: 87
Congratulations with your new car!

I agree; I need to make a big turn with the steering wheel before the indicators are off. I have gotten used to turn my indicators of manually. However, a difference between the left indicator and the right one is not so good. Best ask your dealer about it...

Happy driving!

Chris_147 is offline  
Status: -
AO Gold Member
Ivo's Avatar
Join Date: Jun 2002
Location: Dutchland
Posts: 7,920

I have exactly the same experience with the indicators. So I guess it's "normal"

Anyway, I like the car not one bit less about this
Ivo is offline  
Status: - Update
Posts: n/a
Cheers Ivo.

Yeah, I agree its no big deal. I just wanted to know if this is something typical or something i should make sure gets addressed by the dealer when it goes in for a service.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , acting , indicators , strangely

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome