Driving a selespeed correctly - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 08-01-09 Thread Starter
Status: -
AO Member
Join Date: Aug 2008
Location: United Kingdom
County: Cambridgeshire
Posts: 415
Images: 4

Member car:

Ford Focus

Driving a selespeed correctly

Are selespeed faults random? Or are there some tips for keeping it all together?

Is it better to whack it in auto for most activities and break (er, wrong word) out the stick shift/paddle for occasional fun times?

I remember reading somewhere that from starting it up, you should always put the brakes on before engaging first from neutral?

I've had one before and before I crashed it, it was becoming temperamental. Any other tips?
what's all this about the sele oil, how should I deal with that?
nayf is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2008
Location: Vatican City State (Holy
County: -
Posts: 45

Member car:

Alfa 156 2.0jts

Re: Driving a selespeed correctly

Generally the selespeed is a pretty reliable system but does need calibrating now and again to allow for wear in components (especially the clutch plate). If gear changes are a bit hit or miss, jerky when setting off etc then time to get it checked. End-of-line calibration, clutch voltage and clutch degradation index are the three most important parameters to get checked/reset. The most common faults I come across are pump relay/terminals, pump motor seizes, occasional clutch disc sensor or clutch unit itself. Oil leaks from the actuator now and again.
You always have to press the brake when selecting a gear from neutral- safety feature.
Using the flappy paddles/stick or auto make no difference to how the system operates and one won't damage the system any more or less than another.

Only two things are infinite: The Universe and human stupidity. And I'm not sure about the former.
slysi16v is offline  
Status: missing Inverurie
AO Gold Member
Pascs's Avatar
Join Date: Apr 2002
Location: Qatar
County: Aberdeenshire
Posts: 8,063
Images: 16

Member car:

Zender 156 V6

Re: Driving a selespeed correctly

I hated the City mode and never used it - I just used the buttons on the steering wheel.

I dont think you can change from neutral to first without your foot on the brake, isnt it a safety feature so you dont knock it into gear by mistake?

Nothing much to the Selespeed oil except to check the level with the ignition on but engine not started.
Pascs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

correctly , driving , selespeed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome