broken indicators/hazards...wheres the relay? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 04-01-09 Thread Starter
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Lincolnshire
Posts: 96
broken indicators/hazards...wheres the relay?

Hi folks. Was driving up M18 tonight and indicators stopped working. Diddly squat on either side, or hazards. I thought aha FUSE blown. Stopped at mcdonalds, checked 10A fuse (number 14) and it was fine. Thought ill just go an tap those relays in the engine bay... and the engine dies...wouldnt start...VDC failure warning. Anyway RAC man sorted it, one of relays id wiggled had dodgy green terminals and had lost its connection. He cleaned it up and engine and VDC woes went away. However we couldnt locate the hazard/indicator relay (its not listed in handbook). We couldnt see it in the drivers fuse compartment or glovebox...and it wasnt one of the engine bay ones as far as the book tells us.

SO where is the relay on a 03 plate 156 2.4 jtd? and would my complete lack of anything flashing (apart from setting/unsetting alarm when all lamps flash as they should) mean that its going to be that relay since the fuse is fine.

haveyoubooked is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2008
Location: Ireland
County: -
Posts: 10

Member car:


Re: broken indicators/hazards...wheres the relay?

the relay is in the steering colum just remove the bottom steering cover 3 skrews its coloured blue it just might need to be jiggerd abit
FAST EDDIE is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

broken , relay

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome