desperate advice needed - 147 - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: desperate advice needed - 147

Originally Posted by teganellie View Post
I guess I just want someone to say - yep thats the problem and this is how we fix it! Thanks for listening and for your help. Much appreciated.
Unfortunately Alfas are fickle things and there are very few online dianosis that can give us a clue as to the exact problem that we just can't nail it over the keys, but the way you say a group of electrical items stoped working which are only linked by one plug under the dash, that is why I think I'd start there, if your electrician gets nowhere then your always welcome to come down (3 hour round trip though) and I'll sort it out.
Smaky is offline  
Sponsored Links
(Post Link) post #27 of 27 Old 24-01-09 Thread Starter
Status: -
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: West Midlands
Posts: 16
Re: desperate advice needed - 147

Many thanks Smaky, I may need to take you up on that offer. My logic says that they are possibly all linked to one place.

I may sound stupid but does that mean that the plug you are referring to is then attached to the engine somewhere and would have to have been reconnected when they put the engine back together?
I will print these posts and take to garage on Monday.
Would that also account for battery drain or is that likely to be a bad earth as previously suggested?

PS apologies to gva kay for calling you geoff - was half asleep!
teganellie is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , advice , desperate , needed

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome