Selespeed or not - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Silver Member
gil_147's Avatar
Join Date: Oct 2005
Location: United Kingdom
County: Tyne and Wear
Posts: 1,634
Images: 11
Re: Selespeed or not

I ran a 147 sele' for 5 years. It was an exquisite car and rewarding to drive , however not without it's problems. Things did go wrong and when it happens it can be very inconvenient. I didn't get any huge bills, but had a few smaller ones. Things will go wrong with the system - it's just a case of when.

Important bit:
I absolutely loved my sele' and don't regret owning it for a second, in fact I miss it. If I was buying another 147 though, or any Alfa for that matter, I would buy a manual - no question.
gil_147 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2007
Posts: 12
Images: 6
Re: Selespeed or not

My Selespeed "up" switch has just gone, fixed it myself tho.Saved myself over one hundred quid. Love it tho.......
Trampy is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome