Cruise Control not working - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: At least the air-con is superfluous now!
AO Member
Head Rat's Avatar
Join Date: Sep 2008
Location: United Kingdom
County: Norfolk
Posts: 40
Images: 9
I had exactly this issue with my broken clutch pedal leading to loss of cruise control. Thanks to this site, a pair of needle nose pliers and a twisted back I can now avoid speeding tickets again!!

Cheers folks!
Head Rat is offline  
Sponsored Links
Status: -
Join Date: Jul 2015
County: -
Posts: 2
My cruise control not working. Autocom show me Brake light switch failure (c1161). But stop lamps work just fine, except middle lamp (but this is boot switch problem). I can't start car if clutch or brake pedal are not pushed. So i think clutch and brake switches are ok. Can be other problem about these switches? Bad switch position ... or else...
Servis changed brake switch, but problem is still on. Failure on, cruise control not work
Any ideas?
Alfa 159 SW 2.4JTD 2006
tuso is offline  
Status: Don't. Cut.
AO Member
sneaker's Avatar
Join Date: May 2013
Location: Romania
County: Timiș
Posts: 110
Images: 1

Member car:

156 8v

You should post in the 159 section. AFAIK the brake switch has 2 connections, one for the CC and one for the stop lights - so I guess it's possible for a single one to go bad.
sneaker is offline  
Status: -
DesmodromicPaul's Avatar
Join Date: Jan 2016
Location: Brittany/Corsica
County: -
Posts: 7
Thumbs Up Wheyy! Thx chaps

fixed the clutch switch as described above which has enabled CC to function - which allowed a successful Proxy Realignment so no more flashing odometer either....
DesmodromicPaul is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , cruise , working

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome