2.4jtd boost controller problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 24-12-08 Thread Starter
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Carmarthenshire
Posts: 129

Member car:

156 2.0

2.4jtd boost controller problems

ok, i think i have found the cause of my low power/smoky issues at low revs. (EGR cleaned, Maf unplugged, all pipe work checked).

when i first start the engine i can see if the actuator immediately draw the rod straight in that controls the variable vanes. then it stays there until 3-4krpm, when it moves a small amount and judders. if i disconnect the boost pipe at the control solenoid, i can move the actuator relatively freely by hand, and if i suck on the pipe i can make it withdraw. which i hope means the problem isn't with the vanes being stuck inside the turbo.so my questions,

1: how should the actuator behave when revving the engine? i'm guessing it should move a noticeable amount between 0-2.5k rpm, and smoothly slide in and out across the rev range.

2: is the boost control solenoid easy to test or fix? or do i have to replace it, i have read they can seize.

hope that all makes sense. I've owned this car 3 weeks and not been able to enjoy driving it yet, just want it fixed now!!

dodge00 is offline  
Sponsored Links
Status: -
AO Silver Member
Join Date: Sep 2007
Location: United Kingdom
County: Derbyshire
Posts: 1,613

Member car:

159 Ti

Re: 2.4jtd boost controller problems

it is boost related therefore it will requir a load, revving on your driveway wil not provide enough load to generate serious boost or movement of the VNT's.

Its a pieburg overboost module and they are abot 40quid, if its suspect then replace it.

Squirting carb cleaner down will merely clean the diaphrams at the op nd not the solonoid area, so leaning it probablywon't help at all.
jasons is offline  
Status: vacuum issue.. help!
AO Member
ShiftyBloke's Avatar
Join Date: Feb 2006
Location: United Kingdom
County: Kent
Posts: 239
Re: 2.4jtd boost controller problems


On the 1.9 it's just below the EGR, on the plastic bit on the back on the inlet manafold... 2.4.. you'll have to trace the vacuum tubes.

I had it when the veins moved freely by hand, but what happened on mine, was the increase heat from the exhust would jam the veins, even though at idle it would move freely.

ShiftyBloke is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

24jtd , boost , controller , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome