147 whirring noise - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-12-08 Thread Starter
Status: -
AO Member
Join Date: Aug 2007
Posts: 70

Member car:

147 JTD

147 whirring noise


I just had the ignition switched on MAR on my 147 JTD, and I made sure that I'd turned everything off, including the climate control, but there was still a consistent whirring noise coming from somewhere behind the climate control display on the central console. It sounds a bit like a fan, possibly. Any ideas what it is?

Is this normal, or something to worry about?

richard.beckett is offline  
Sponsored Links
Status: too cold for motorbikes back in the car
AO Member
Join Date: Dec 2008
Location: United Kingdom
County: Staffordshire
Posts: 792
Re: 147 whirring noise

mine does it after you turn ignition off ,you notice it if you sit in a bit longer than you would .my old 147 did it as well and the wife's so don't think owt to worry about .perhaps its an automatic fan to cool controls down or summat.hope this helps mate
jackojet is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , noise , whirring

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome