HELP! 156 Door open light. - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 10-02-03 Thread Starter
Status: -
AO Member
Marelli's Avatar
Join Date: Mar 2002
Location: Norfolk
Posts: 64
HELP! 156 Door open light.

On the way home tonight, the dashboard light indicating that the driver's door was open came on a few times-the door was definately shut!

Any ideas what the problem may be and how easy it is to fix?

About five minutes after parking the car, the alarm went off so it looks like the car "thought" the door was open again.

This last bit might sound a bit mad-I'm sure that the radio reception was worse just before the light was coming on as the interference went when it was fully lit (it strted off with just a faint flickering).

All suggestions gratefully received. Thanks in anticipation.
Marelli is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2003
Location: United Kingdom
County: Cornwall
Posts: 325
Hiya Marelli
Had a similar problem on my 156. I rang the dealer who said; turn the ignition off with the door open,then shut the door and turn the ignition back on with the door shut. It sounds daft but it works. However in your case, if the radio is effected it might be an earth wire somewhere. I will have a look on my wiring diagram (CD) when I get home tonight and see if there is a common earth.
alibob is offline  
Status: -
AO Member
y2k156's Avatar
Join Date: Oct 2002
Posts: 112
I've also discovered that the rear passenger roof light can be deactivated.

To deactivate-open the rear door, press the light cover to turn it off and shut the door. To activate it again, open the door(the lights will be off) and press it on.

Was this mentioned in the Owner's manual?
y2k156 is offline  
Status: Using the hand brake a lot!
AO Member
Mogens's Avatar
Join Date: Jul 2002
Location: Denmark
Posts: 120
And reenabling the light again???

My right side rear passenger light thingie does not work when activating the switch in the lamp, it only works when you open the door??

The left side works fine.

Standard Alfa wiring again?

Mogens is offline  
Status: -
AO Member
y2k156's Avatar
Join Date: Oct 2002
Posts: 112
That was the problem I had, I thought the bulb was blown, so I tried pressing the light with the door closed, it worked. After that, I opened the door, didn't light. I pressed it again with the door open and then shut the door. The next time I opened the door, it worked fine, just like the other door. That's how I found out it can be disabled/enabled. Good luck in trying yours.
y2k156 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , door , light , open

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome