brake light alfa 156 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-12-08 Thread Starter
Status: [Too Long]
AO Silver Member
crespo2121's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Dorset
Posts: 1,109
Help brake light alfa 156

my right hand side brake light bulb keeps on not working.
its not the bulb as every time i take a look its fine then i put it back in and its fine for 10 minutes. then it stops working.
this is now driving me nuts.
can i spray it with wd40 or will that ruin the bulb unit.
please help as it has got to the point that when it happens now i go in to a rage and start cussing like a epilectic with tourettes. people are begining to think im mad.
it is getting to the point where i shall be doing a bassil faulty and be beating the car with a stick soon.
crespo2121 is offline  
Sponsored Links
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
Re: brake light alfa 156

sometimes the 'leaf-spring' connection goes flat, try pullint it upwards to make better contact.

or else the wiring to the connector is dodgey
SEARs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , alfa , brake , light

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome