Anyone got a rear wiper motor assembly? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 13-12-08 Thread Starter
Status: -
Club Member
Membro Premio
Big Jon's Avatar
Club Member Number: 42
Join Date: Sep 2004
Location: United Kingdom
County: Antrim
Posts: 2,994
Anyone got a rear wiper motor assembly?

My rear wiper motor is dying a death. It barely drags the wiper across the rear screen. I've had it apary and the mechanism is well greased and I've cleaned the gunk from around the spindle below the wiper arm but to no avail.

Anyone breaking a 147? Or how much is a new one?
Big Jon is offline  
Sponsored Links
Status: -
AO Member
RS232's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Wiltshire
Posts: 432

Member car:

Alfa 156 2.4JTD

Re: Anyone got a rear wiper motor assembly?

Hi, just did it to mine 156, the motor would move very slowly or not at all.
The problem is the metal rod that goes from the gears to the wiper arm.
Remove the back plastic cover and the nut on the wiper arm.
There is a lock ring and a washer on top of the metal rod.
Pay atention to the position of the gears inside the box.
Push the rod from the outside to the inside,( it may be dificult to do, I used a hammer and a smaller diameter rod to get it out).
With the rod out just clean the rod (rust on top) with sand paper.
Grease it and put everything back together(pay atention to the gears position).
Hope it helps, mine is working fine since I did the job.


Last edited by RS232; 13-12-08 at 18:55.
RS232 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

assembly , motor , rear , wiper

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome