Sticky accelerator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 09-12-08 Thread Starter
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Cambridgeshire
Posts: 35
Hmmm Sticky accelerator

Hi All

I have a 2001 Alfa 147, 1.6l TS, great fun to drive and even after having it for just over a month I have used the RAC once when the clutch pedal decided to fall off.

Despite its many 'quirks' it is great to drive...

I took her out for a spin last night and discovered that the accelerator is sticking. When I change up the process is...

1. Foot off accelerator
2. Clutch Down
3 Gear change
4 Clutch up
5 Accelerate

Pretty normal. Only problem is that between 1 and 2 the throttle blips (I say 'blip' but it revs between 1-2 thousand more than it is already doing). Is this a sign of the accelerator sticking?

What should i do about it?

Any advice would be much appreciated! Thanks
compaq1024 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

accelerator , sticky

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome