156 Power Steering - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 08-12-08 Thread Starter
Status: -
AO Member
Join Date: Oct 2008
Location: United Kingdom
County: Hampshire
Posts: 16

Member car:

156 1.9JTD 2004

156 Power Steering

My wife's 156 is a 1998 R-reg 2.0 TS - so a pretty early model (the car as well). The power steering has always been poor at low engine speeds - fine at 1800 rpm or more, but when parking or manoeuvring at idle speed it feels as though there's no assistance at all. Now the garage has failed it on MOT as it's a 'steering-related failure'. So my questions are:

Is this a common fault?
What causes it?
How can I fix it?
Should it fail an MOT because of the fault?

Your advice please!
correlejco is offline  
Sponsored Links
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,991
Re: 156 Power Steering

If there is a problem with the steering then yes it should fail its MOT...!

Not a common problem though and I can't remember it coming up before.

I presume you have already checked the fluid level?
David C is offline  
Status: -
Join Date: Oct 2008
Location: Ireland
County: Wexford
Posts: 4,646
Re: 156 Power Steering

could be a loose AUX belt or else a defective pump
SEARs is offline  
Status: -
AO Member
longcaster's Avatar
Join Date: Dec 2008
Location: United Kingdom
County: Staffordshire
Posts: 42

Member car:

156 2.5 v6 lusso

Re: 156 Power Steering

ive got a 156 v6 and was just about to post the same question noticed it more today cus bin around shopping at various carparks and thought to my self dont need to be replacing a pump this side of xmas just hope my clucth holds out tooo!!
longcaster is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

156 , power , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome