Unsolvable Motor Control System Failure - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-11-08 Thread Starter
Status: -
Join Date: Apr 2008
Location: United Kingdom
County: Derbyshire
Posts: 8

Member car:

Giulietta JTDM

Madness Unsolvable Motor Control System Failure

I bought by 54 Approved Used 156 JTS in February 08 after years of yearnng for an alfa. However, it has been back to the dealers in Derby about ten times with the dreaded MCSF.

There is a regular pattern to it. It only happens about 1 minute after starting from cold and lasts about 1 minute before it goes again. The car drives fine. It doen't happen every time. Probably more often when it is cold and damp. The dealer hooks it up to his computer and it reports a misfire, but there are none of the usual symptoms of a misfire.

He has changed most of the things suggested on this forum (Lambda sensors, MAF, fuel injectors coils ets etc) but no joy.

The one thing don't think he has ever mentioned is replacing the battery. This is suggested lots in this forum. Could it be the battery? Why would the battery be causing my problems?

Starting to loose the plot now!
fifer1973 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Re: Unsolvable Motor Control System Failure

its probably the battery or a dodgy connection to it
Status: -
AO Member
charlie8's Avatar
Join Date: Jun 2005
Posts: 106

Member car:

GT JTS 2.0

Re: Unsolvable Motor Control System Failure

Sounds similar to my issues that went on for months. I never had any indication other than the dash that something was wrong, it always ran fine and always came on about 4 miles in the journey.

Issue - lambda cable was resting on manifold as it has been pulled out of loom clip ( when the jokers did the cambelt change ). As the car heated up the resistance changed enough in the cable to give rouge relative signals. I just tied the cable onto the loom away from exhaust, 5 starts later to clear the fault and all has been fine for months and months.

Worth a check

These systems are soooo sensitive and based on grafting data.


There's nothing in the dark that isn't there in the light ..... except fear
charlie8 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

control , failure , motor , system , unsolvable

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome