Suspension?! beeping when GT is cold? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-11-08 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 69

Member car:

Alfa GT

Suspension?! beeping when GT is cold?

About crashy GT's ride.
I found on my GT that when the car is cold, the first 10 minutes the suspension or I don't know what somehow "beebs" if I drive over a holes in a road, or over a not even road surface. The sound is comming more from the front part of the car and the sound isn't metal-rattling but it really beeps like "Wooeeyp"
What I have to change to repair that beeping sound? Any advices?

Thank you!
Photoblaz is offline  
Sponsored Links
Status: -
AO Member
Sensible's Avatar
Join Date: Aug 2006
Location: Halesowen, West Mids
Posts: 368
Re: Suspension?! beeping when GT is cold?

Could this be described as a squeak.

I had a sqeeking noise coming from the front of the car on both sides, on my 156, when I went over bumps in the road.

Took it to my Alfa chap that I use and he changed the top arm on the nearside and put silicon on the bushes on the offside. It seems to have solved the problem. I only accasionally get the squeak from the offside when it is cold now. I'm sure I will eventaully have to have that one changed.

I think these do wear out, and the GT has the same suspension as the 156 (I think). If it is this there are plenty of threads about it and how to change them if your DIY minded.
Sensible is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

beeping , cold , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome