ARGHHH New turbo req? pls no - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 27-11-08 Thread Starter
Status: -
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: Cheshire
Posts: 21

Member car:

156 2.4 JTD 20V

Madness ARGHHH New turbo req? pls no

Ive just had a 'Go to main dealer, engine management' light flash up and complete loss of my turbo. Car still works but after 30mph there jack all performance, pls tell me i dont need a new turbo????

Also any ideas a) what made/ n umber of turbo is in a 2004 2.4 JTD?
and any pointers to cost/ websites?

all help gratefully recieved, i currently feel sick as a dog...........
Alfafanman is offline  
Sponsored Links
Status: age is only a number ;-)
AO Gold Member
rgwm's Avatar
Join Date: Aug 2004
Posts: 9,069
Re: ARGHHH New turbo req? pls no

It's always worth doing a quick check of all the various air of these falling off can dramatically affect performance - I once had a Vectra TD (I know, but I was running a breakers and got it dirt-cheap) and periodically the engine management light would come on and the performance was crap - after a few months, I found a small (about 2mm) pipe was disconnected from a rubber elbow - reconnected it and WOW! - I had a turbo, performance, no management light......I was so embarassed with myself for not spotting it earlier!

For a recon turbo, if it comes to that, have a look in the Auto-trader - usually several firms advertising. Usual suspects may have second-hand ones....tho I haven't!


AROC Vice-Chairman and Lancashire Section Secretary

Alfa organ donor to the gentry......
rgwm is offline  
Status: -
AO Member
Join Date: Jan 2008
Location: United Kingdom
County: Lincolnshire
Posts: 203
Re: ARGHHH New turbo req? pls no

similar problem on a zafira td it was the pipe running into the wastegate valve pulled it out gave it a blow through reconnected an bingo turbo was back

so hoping yours is as easy
terrycarter is offline  
Status: -
AO Silver Member
Join Date: Sep 2007
Location: United Kingdom
County: Derbyshire
Posts: 1,613

Member car:

159 Ti

Re: ARGHHH New turbo req? pls no

need more info than no drive over 30mph.

does it smoke?
when does it come on boost?
when does the management light come on - what happen just before?
could be anything from a split boost pipe, to split before turbo yet after amf, to bad amf, map sensor or sticking veins. even bad fuel press sensor.
need more info just to give a guess.
jasons is offline  
Status: Paternal
AO Silver Member
Simon_S's Avatar
Join Date: Oct 2001
Location: United Kingdom
County: Warwickshire
Posts: 1,322
Images: 5
Re: ARGHHH New turbo req? pls no

Could be the MAF on its way out, mine would only idle when it went. Unplug its electrical connector (on the pipe from the air filter to the turbo), if the car drives better then you have your culprit.
Simon_S is offline  
Status: -
AO Member
Hugh Myles's Avatar
Join Date: Aug 2007
Location: Sligo, Ireland.
Posts: 788

Member car:

156 2.4 JTD SW

Re: ARGHHH New turbo req? pls no

The car says go to main dealer. That would indicate a need for a mechanic to have a look. It would probably be a good place to start the investigation.
Hugh Myles is offline  
Status: Slumming it
AO Silver Member
MPH's Avatar
Join Date: Oct 2006
Location: Tokelau
County: Nukunonu
Posts: 5,551
Re: ARGHHH New turbo req? pls no

First guess would be the MAF.
As simon said, unplugging the electrical sensor on the MAF could rule that out. MUCH cheaper than a new turbo.
A good independant garage should be able to sort you out no probs with the troubleshooting.
MPH is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

arghhh , pls , req , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome