147 timing belt - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 20-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: United Kingdom
County: -
Posts: 1

Member car:

147 2litre

147 timing belt

My timing belt has just broken at 47000 miles. Is yhe engine interference or non- interference (HOPING SO)
carlorinaldi is offline  
Sponsored Links
Status: The BSD says konnichiwa
Global Mod Team
BigFoot's Avatar
Join Date: Jul 2003
Location: Italy
County: Milano
Posts: 113,594
Images: 14
Re: 147 timing belt

Moved to 147 Tech Lounge
BigFoot is offline  
Status: Freezing!
AO Silver Member
Rockhopper's Avatar
Join Date: Mar 2007
Location: United Kingdom
County: Nottinghamshire
Posts: 4,861
Re: 147 timing belt

Its interference as a quick forum search would have shown you! New engine time i'm afraid. Belt change interval is 36,000 miles or three years.
Rockhopper is offline  
Status: -
AO Platinum Member
David C's Avatar
Join Date: Aug 2003
Location: London, England
Posts: 28,990
Re: 147 timing belt

As above it is an interference type and you should have replaced the belts at least 11000miles ago.
The interval changed to 36000miles/3-years in November 2006 (2-years ago).
David C is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , belt , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome