Actuator - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-11-08 Thread Starter
Status: -
Join Date: Nov 2008
Location: Australia
County: New South Wales
Posts: 3

Member car:


Cry Like A Baby Actuator

Hi guys,

I posted a few weeks ago about replacing my actuator. Mechanic said its going to cost $4.5k . Problem was it kept shifting to neutral and dashboard warnings going off every 10 minutes or so. Also wouldn't let me reversed properly - would shift to neutral about 2 seconds after I put it into reverse. I also have to put the gear into 1st and accelerate really quickly if not it would change back into neutral.


Well because I just bought the car and it was already back at the dealer in no less than a month, I still have statutory warranty PLUS extra warranty that I bought.

The warranty that I bought clearly states that it does not cover selespeed motor.. that says a lot about their reputation. . Would the actuator fall under this? Anyways, the warranty is capped at $1.5k so I have another $4k to worry about.

The statutory warranty. Now, anyone from Australia can help me out abit here? There's absolutely no point in me asking the dealer as he'll probably just tell me my problem isn't covered so he won't have to deal with it. . I asked the mechanic and he says that its a pretty grey area - if its wear and tear then no its not covered. I didn't think the actuator is a wear and tear component? .

Yes, I am quite a girl.

Any help would be appreciated! You guys are the best.
jane[y] is offline  
Sponsored Links
Status: Gold Member
AO Gold Member
rarebear's Avatar
Join Date: Sep 2002
Location: The Netherlands
Posts: 7,021
Re: Actuator

4.5 k$ sounds far too high, these parts can be had at a breaker for 200... in many cases there are bad connections in the system and the actuator is in good nick. Wish I could help but Holland is too far away from down under.. I wish you strenght !
rarebear is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome