Alfa 147 MOt looming.... - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 19-11-08 Thread Starter
Status: -
AO Member
Join Date: Dec 2006
Location: aberdeen, scotland
Posts: 23

Member car:


Alfa 147 MOt looming....


I have tried various searches for this issue with no real answer.

Firstly I have the MOT next weekend on the 147 and am dreading it. The problem I have is with the brakes/ABS/Speedo.

When I am on the go the speedo is VERY erratic and fluctuates up to 10mph either way even when I am going at a constant speed! The brake pedal seem to be "throbbing" or "pulsating" when I try and brake. It's harder to brake and if i'm not holding the wheel the steering turns to the right when breaking!! If I leave this for a couple of miles and speed up I get the ABS failure light and ASR failure on. Funnily enough as soon as this happens everything goes back to normal and the brakes and speedo work just perfect!

This happened a good few months back and I just removed the ABS fuse under the steering wheel. Now that my MOT is due i've put the fuse back in and am back to square one!

Any advice on this? Someone told me it could be the ABS sensor in the wheel is kapput?

marclangford is offline  
Sponsored Links
Status: -
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: Derbyshire
Posts: 94

Member car:


Re: Alfa 147 MOt looming....

If the brake throbbing is as in the feel you get when the abs is acivating then coupled that with the fluctuating speedo which I'd expect to take its feed from the abs system then a dodgy sensor sounds about right. I'm sure someone with more knowledge will be along shortly though.
montrose is offline  
Status: Quieter now...
AO Member
Join Date: Nov 2007
Location: Lutterworth, UK
Posts: 303
Re: Alfa 147 MOt looming....

Sounds like you have pretty severe brake imbalance. I predict that the car will fail the MOT.

My previous 145 had this after new brakes were fitted to the front, but not too severe so as to fail the MOT. This car initially pulled to the left on application of the brakes before the right brake bit and the car straightened up.
RBaron is offline  
Status: -
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: Tyne and Wear
Posts: 23

Member car:


Re: Alfa 147 MOt looming....

the way ur saying i would say its a abs sensor not reading correctly

as when the light comes on it disables the abs and then you say it works correctly

req sensors checking ull find one is a different speed
Jack is offline  
Status: -
AO Member
Join Date: Feb 2007
Location: United Kingdom
County: Cardiff
Posts: 683
Re: Alfa 147 MOt looming....

I'd get diagnostics done on the ABS system. I think it'll probably come up with a sensor acting up.
Escy is offline  
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: Alfa 147 MOt looming....

Sounds to me like the front right brake calliper is siezed or the disc is severely warped, either way it's worth replacing the discs and pads before the MOT.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , alfa , looming , mot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome