Squeeky start up 147 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 18-11-08 Thread Starter
Status: -
AO Silver Member
corbo's Avatar
Join Date: May 2008
Location: United Kingdom
County: Somerset
Posts: 1,610
Squeeky start up 147

For the last couple of mornings when I start the car there is a squeeky noise coming from under the bonnet, I think it's on the drivers side. It lasts for about 5 seconds and doesn't come back. Sounds like a belt perhaps but my ears aren't mechanically trained.

Car drives fine. I have a service coming up, what is this likely to be? I'll get them to check it out.

corbo is offline  
Sponsored Links
Status: -
AO Member
Join Date: Nov 2008
Location: Lebanon
County: -
Posts: 86
Re: Squeeky start up 147

i reckon it is the strater motor, have it greased properly and you wont hear the sqeeky noise again, keep me posted
lallous is offline  
Status: Alfa infected
AO Gold Member
purple145's Avatar
Join Date: Oct 2004
Location: United Kingdom
County: West Midlands
Posts: 7,026
Re: Squeeky start up 147

if its like my 145, it could be the aux belt tensioner or idler pulleys, about £35 each IIRC from shop4parts

purple145 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , squeeky , start

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome