possible battery problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 16-11-08 Thread Starter
Status: burble
AO Silver Member
punt14's Avatar
Join Date: Oct 2008
Location: United Kingdom
County: Durham
Posts: 1,925

Member car:

VW Tiguan smoker

possible battery problems

i have a 52 plate 147 1.6 of late my odometer was flashing but i turned my car off and turned it back on and it went back to normal then about an hour ago mcsf came on so turned the car off and turned it back on then it went off. i have read that the flashing odometer could be because of the battery and i was just seeing if the mcsf could be related. oh and the battery is the original Alfa one and their is no receipts of it being replaced could that be the cause thanks in advance
punt14 is offline  
Sponsored Links
Status: Banned for not following the site rules
Join Date: Feb 2008
Location: United Kingdom
County: Wiltshire
Posts: 9,721
Images: 6
Re: possible battery problems

Very likely to be the battery, also make sure the alternator is charging and the battery terminals are still tightened down right.
Smaky is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

battery , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome