147 knocking sound when driving - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 11-11-08 Thread Starter
Status: -
AO Silver Member
Jack 147's Avatar
Join Date: Nov 2008
Location: United Kingdom
County: Durham
Posts: 2,772

Member car:

Alfa 147 1.6 TS

147 knocking sound when driving

There is a knocking sound developed on the passenger side when driving over bumps. I suspect there is a problem with the bushes. Have you got any other ideas that could cause this problem?
Jack 147 is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2008
Location: United Kingdom
County: West Lothian
Posts: 143

Member car:


Re: 147 knocking sound when driving

roll bar links or at worst lower wishbone or arb bushes
MarkoGT is offline  
Status: -
AO Member
pyrean's Avatar
Join Date: Jun 2007
Location: Cape Town, South Africa
Posts: 76

Member car:

147 1.6

Re: 147 knocking sound when driving


I had a similar problem, it ended up being the upper control arm balljoint. At first I could not notice any play on the suspensions when moving the wheel by hand. Later as the wearing became worse it was very loose and I could actually wiggle the wheel. If I sent it in earlier I could have had the ball joint repaired, but in the end I needed to replace it at great cost.

pyrean is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 147, 156 & GT

147 , driving , knocking , sound

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome